收集 Zix Email Encryption 記錄
本文說明如何使用 Bindplane 代理程式,將 Zix Email Encryption 記錄檔擷取至 Google Security Operations。
Zix Email Encryption (現為 OpenText ZixEncrypt) 是電子郵件加密和資料遺失防護平台,可確保電子郵件通訊安全並符合法規。系統會在 ZixGateway 設備上產生 SMTP 交易記錄和加密事件記錄。
事前準備
請確認您符合下列必要條件:
- Google SecOps 執行個體
- Windows Server 2016 以上版本,或搭載
systemd的 Linux 主機 - Bindplane 代理程式與 Zix Email Encryption 設備之間的網路連線
- 如果是在 Proxy 後方執行,請確認防火牆通訊埠已按照 Bindplane 代理程式規定開啟
- 具備管理員權限,可存取 Zix Email Encryption 設備 (ZixGateway) 的特殊存取權
- 存取 Zix Email Encryption 記錄檔 (SMTP 交易記錄、加密事件記錄)
取得 Bindplane 代理程式的 Google SecOps 憑證
如要向 Google SecOps 驗證 Bindplane 代理程式,請選擇下列其中一種方法:
- 新部署作業:使用 Chronicle API (選項 1)。
- 舊版部署作業:繼續使用擷取驗證檔案 (選項 2),直到 Ingestion API 於 2027 年 7 月 20 日停用。
方法 1:為 Chronicle API 建立服務帳戶 (建議)
- 登入 Google Cloud 控制台,選取連結至 Google SecOps 執行個體的 Google Cloud 專案。
- 依序前往「IAM & Admin」(IAM 與管理) >「Service Accounts」(服務帳戶)。
- 按一下「建立服務帳戶」。
- 提供下列設定詳細資料:
- 服務帳戶名稱:輸入帳戶名稱 (例如
bindplane-ingest)。 - 「服務帳戶說明」:輸入說明 (例如
Bindplane agent log ingestion)。
- 服務帳戶名稱:輸入帳戶名稱 (例如
- 點按「Create and continue」(建立並繼續)。
- 在「將專案存取權授予這個服務帳戶」部分,按一下「選取角色」,然後選取「Chronicle 編輯者」。
- 依序點選「繼續」和「完成」。
- 按一下您建立的服務帳戶,然後前往「金鑰」分頁。
- 依序點選「新增金鑰」>「建立新的金鑰」。
- 選取「JSON」,然後點選「建立」。金鑰檔案會下載到電腦。
- 將金鑰檔案儲存為 Bindplane 收集器目錄中的
ingestion-auth.json(Linux 上的/opt/observiq-otel-collector/ingestion-auth.json或 Windows 上的C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json),或更新config.yaml中的creds_file_path,使其與儲存路徑相符。 - 依序前往「IAM & Admin」(IAM 與管理) >「Settings」(設定),然後複製「Project number」(專案編號)。設定匯出工具時會用到。
方法 2:下載擷取驗證檔案 (舊版)
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」>「收集代理程式」。
- 下載擷取驗證檔案。
- 將檔案安全地儲存在要安裝 Bindplane 代理程式的系統上。
取得 Google SecOps 客戶 ID
- 登入 Google SecOps 控制台。
- 依序前往「SIEM 設定」 > 「設定檔」。
複製並儲存「機構詳細資料」部分的客戶 ID。
安裝 Bindplane 代理程式
請按照下列操作說明,在 Windows 或 Linux 作業系統上安裝 Bindplane 代理程式。
Windows 安裝
- 以管理員身分開啟命令提示字元或 PowerShell。
執行下列指令:
msiexec /i "https://github.com/observIQ/bindplane-agent/releases/latest/download/observiq-otel-collector.msi" /quiet等待安裝完成。
執行下列指令,確認安裝成功:
sc query observiq-otel-collector服務應顯示為「RUNNING」。
安裝 Linux
- 開啟具有根層級或 sudo 權限的終端機。
執行下列指令:
sudo sh -c "$(curl -fsSlL https://github.com/observiq/bindplane-agent/releases/latest/download/install_unix.sh)" install_unix.sh等待安裝完成。
執行下列指令,確認安裝成功:
sudo systemctl status observiq-otel-collector服務應顯示為「active (running)」。
其他安裝資源
如需其他安裝選項和疑難排解資訊,請參閱 Bindplane 代理程式安裝指南。
設定 Bindplane 代理程式,擷取系統記錄並傳送至 Google SecOps
找出設定檔
Linux:
sudo nano /opt/observiq-otel-collector/config.yamlWindows:
notepad "C:\Program Files\observIQ OpenTelemetry Collector\config.yaml"
編輯設定檔
將
config.yaml的全部內容替換為下列設定:receivers: filelog: include: - /var/log/zix/*.log - /opt/zix/logs/*.log start_at: beginning exporters: chronicle/zix_email: protocol: https # Region of your instance, for example us, europe, asia-southeast1 location: <LOCATION> # Project number of the Google Cloud project linked to the instance project: '<PROJECT_NUMBER>' compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: chronicle.googleapis.com log_type: ZIX_EMAIL_ENCRYPTION raw_log_field: body ingestion_labels: env: production service: pipelines: logs/zix_to_chronicle: receivers: - filelog exporters: - chronicle/zix_email
設定參數
替換下列預留位置:
接收器設定:
filelog:從磁碟收集記錄檔的接收器類型include:要監控的檔案路徑或 glob 模式清單:- Linux:
/var/log/zix/*.log或/opt/zix/logs/*.log - Windows:
C:\Program Files\Zix\logs\*.log - 調整路徑,使其與 ZixGateway 記錄檔位置相符
- Linux:
start_at:設為beginning可從頭讀取現有記錄檔,設為end則只會讀取新項目
Exporter 設定:
zix_email:匯出工具的說明名稱creds_file_path:服務帳戶 JSON 金鑰檔案的完整路徑 (選項 1):- Linux:
/opt/observiq-otel-collector/ingestion-auth.json - Windows:
C:\Program Files\observIQ OpenTelemetry Collector\ingestion-auth.json
- Linux:
<customer_id>:上一步中的客戶 IDlocation:將<LOCATION>替換為 Google SecOps 執行個體的區域 (例如us、europe或asia-southeast1)。匯出工具會以這個值做為chronicle.googleapis.com的前置字元。如需完整清單,請參閱「區域性端點」。project:將<PROJECT_NUMBER>替換為「IAM 與管理」>「設定」中的專案編號。endpoint:維持設為chronicle.googleapis.com。ZIX_EMAIL_ENCRYPTION:記錄類型,與 Chronicle 中顯示的完全相同ingestion_labels:YAML 格式的選用標籤 (例如env: production)
管道設定:
zix_to_chronicle:管道的說明名稱
舊版 Ingestion API 匯出工具
如果您使用選項 2 的擷取驗證檔案,請將
exporters區塊替換為下列內容。將creds_file_path設為擷取驗證檔案的路徑。如果執行個體位於美國境外,請將malachiteingestion-pa.googleapis.com替換為區域端點 (例如europe-malachiteingestion-pa.googleapis.com)。exporters: chronicle/zix_email: compression: gzip creds_file_path: '/opt/observiq-otel-collector/ingestion-auth.json' customer_id: '<customer_id>' endpoint: malachiteingestion-pa.googleapis.com log_type: ZIX_EMAIL_ENCRYPTION raw_log_field: body ingestion_labels: env: production
儲存設定檔
- 編輯完畢後,請儲存檔案:
- Linux:依序按下
Ctrl+O、Enter和Ctrl+X - Windows:依序點選「檔案」>「儲存」
- Linux:依序按下
重新啟動 Bindplane 代理程式,套用變更
如要在 Linux 重新啟動 Bindplane 代理程式,請執行下列指令:
sudo systemctl restart observiq-otel-collector確認服務正在執行:
sudo systemctl status observiq-otel-collector查看記錄檔是否有錯誤:
sudo journalctl -u observiq-otel-collector -f
如要在 Windows 中重新啟動 Bindplane 代理程式,請選擇下列任一選項:
以管理員身分開啟命令提示字元或 PowerShell:
net stop observiq-otel-collector && net start observiq-otel-collector服務控制台:
- 按下
Win+R鍵,輸入services.msc,然後按下 Enter 鍵。 - 找出「observIQ OpenTelemetry Collector」。
- 按一下滑鼠右鍵,然後選取「重新啟動」。
確認服務是否正在執行:
sc query observiq-otel-collector檢查記錄是否有錯誤:
type "C:\Program Files\observIQ OpenTelemetry Collector\log\collector.log"
- 按下
設定 Zix Email Encryption 記錄收集
Bindplane 代理程式會直接從 ZixGateway 設備檔案系統收集記錄檔。
確認記錄檔位置
- 登入 ZixGateway 管理控制台。
- 依序前往「監控」>「記錄」。
驗證記錄檔目錄:
- Linux:
/var/log/zix/或/opt/zix/logs/ - Windows:
C:\Program Files\Zix\logs\
- Linux:
確認系統是否將 SMTP 交易記錄和加密事件記錄寫入預期位置。
如果記錄目錄與預設值不同,請更新 Bindplane 代理程式
config.yaml中的include路徑。
UDM 對應表
| 記錄欄位 | UDM 對應 | 邏輯 |
|---|---|---|
| 中介 | 中介 | 從中介銀行合併 |
| relay_host | intermediary.hostname | 直接從 relay_host 複製的值 |
| relay_ip | intermediary.ip | 從 relay_ip 合併 |
| relay_port | intermediary.port | relay_port 的值已轉換為整數 |
| message_details | metadata.description | 直接從 smtp、smtpd、cleanup 或 error 區塊的 message_details 複製值 |
| principal_hostname、sender_email | metadata.event_type | 如果 principal_hostname 和 sender_email 不為空白,則設為「EMAIL_TRANSACTION」;如果 principal_hostname 和 (target_host 或 target_ip) 不為空白,則設為「NETWORK_CONNECTION」;如果 principal_hostname 不為空白,且 (target_host 或 target_ip) 為空白,則設為「STATUS_UPDATE」;否則設為「GENERIC_EVENT」 |
| metadata.product_name | 設為「Zix Email Encryption」 | |
| metadata.vendor_name | 設為「Zix」 | |
| 訊息 | network.application_protocol | 如果訊息符合 SMTP 或 SMTpd,請設為「SMTP」 |
| sender_email | network.email.from | 如果 sender_email 與電子郵件規則運算式相符,則直接複製值 |
| 主旨 | network.email.subject | 從主體合併 |
| recipient_email | network.email.to | 如果符合電子郵件規則運算式,則從 recipient_email 合併 |
| data_size | network.received_bytes | 從 data_size 轉換為 uinteger 的值 |
| tls_cipher | network.tls.cipher | 直接從 tls_cipher 複製的值 |
| cert_data | network.tls.client.certificate.issuer | 直接從 cert_data 複製的值 |
| Daemon | principal.application | 直接從精靈複製的值 |
| principal_hostname | principal.hostname | 直接從 principal_hostname 複製的值 |
| 檔案 | principal.process.file.full_path | 直接從檔案複製的值 |
| pid | principal.process.pid | 直接從 pid 複製的值 |
| principal.resource.type | 如果 daemon 是清除作業,請設為「CLEANUP_MESSAGE_ID」 | |
| sender_email | principal.user.user_display_name | 如果 sender_email 與電子郵件規則運算式不符,則直接複製值 |
| user_id | principal.user.userid | 如果 user_id 不為空值,則取自該值;否則取自 else 區塊中的 user_id |
| security_result | security_result | 從 security_result 合併 |
| security_action | security_result.action | 從 security_action 合併 |
| failure_reason | security_result.description | 直接從 failure_reason 複製的值 |
| security_summary | security_result.summary | 直接從 security_summary 複製的值 |
| 檔案 | target.file.full_path | 直接從檔案複製的值 |
| target_host | target.hostname | 直接從 target_host 複製的值 |
| target_ip | target.ip | 從 target_ip 合併 |
| target_port | target.port | target_port 的值已轉換為整數 |
| message_id | target.resource.name | 直接從 message_id 複製的值 |
| recipient_email | target.user.user_display_name | 如果 recipient_email 與電子郵件規則運算式不符,則直接複製值 |
變更記錄
還有其他問題嗎?向社群成員和 Google SecOps 專業人員尋求解答。